Как установить 64-битные библиотеки в 32-битной системе?

Мне нужно для кросс-компиляции для 64-разрядной архитектуры на 32-разрядной платформе (с помощью GCC-multilib, и -М64 флаг).

Для этого мне нужно установить 64-разрядные версии зависимых библиотек.

Как мне это сделать?

+895
Papajohn 15 сент. 2011 г., 9:36:04
22 ответов

Про перевод, Я люблю его очень много, потому что тема атмосфера. Но если по сравнению с Openbox и я должен признать, что он достаточно тяжелый. Приемник Openbox использует только 6.6 Мб оперативной памяти с 0% процессора на моем ноутбуке. Поэтому, если вы собираетесь на скорости, дают Openbox попробовать.

+983
Dmitri Tsoy 03 февр. '09 в 4:24

Я написал небольшой bash-скрипт для извлечения аудио из видео файлов в пакетном режиме.

Звук извлекается из каждой файл MP4 в FLAC формате через avconv (и Флак кодек).

#!/Бен/ш
#
# Пакетный режим конвертирования извлечение аудио из видео

FOLDER_SRC="/домой/мне/музыка/TestBatchConv"

для myvid В $(найти ${FOLDER_SRC} | грэп МР4)
делать
avconv -я $myvid -acodec Флак "${myvid}.Флак"
сделано

выход 0

Он отлично работает, но я хотел бы улучшить его.

Скрипт распознает только формат MP4. Можно ли признать видеофайл с командой (вместо проверки каждого формата видео) ?

Спасибо за советы.

+965
ysgc 15 февр. 2010 г., 3:25:43

mpd-это не что-то вроде mplayer. Его музыкальный демон-плеером. Вы должны выбрать папку, чтобы добавить песни в свою библиотеку.

Нельзя использовать mpd, чтобы играть один файл. Если вы хотите воспроизвести файл, сначала нужно добавить его в библиотеку, а затем обновить базу данных и затем добавить этот файл в плейлист. кач-это всего лишь интерфейс клиента, чтобы контролировать демона.

Так вот мурз занимается работой, а не кач.

+842
Jon Wadsworth 31 июл. 2012 г., 19:44:54

Я установил сервер Ubuntu 12.4 в виртуальном поле в Oracle, после установки, я не могу использовать сервер Ubuntu в полном экране,оценки поступлений в виртуальном поле будет работать в Ubuntu сервер.

+750
aaronskania 14 нояб. 2016 г., 9:51:23

"после перезагрузки: файл не найден, жратва спасения Промт" это означает, что grub ядра.ИМГ, встроенные в пост-МБР разрыв, ищет в /boot/grub/ с на неверный раздел.

"После набора префикса, выделяют корень, insmod приходит: неверный арки независимых эльфийская магия". Это означает, что файл /boot/grub/ С, который вы указывали жратвы-это для другой версии жратвы, чем версия grub, что встроенного ядра.ИМГ пришли.

Эти две вещи сильно предполагают, что ядро.ИМГ встроенные в пост-МБР разрыв с предыдущей Убунту установить, не из вашей последней установки Ubuntu 12.04. Чтобы исправить это, вы должны запустить grub-install, которая при запуске с LiveCD, либо требует изолированной или ... загрузки-каталог= аргумент, и убедитесь, что вы рассказать жратвы-установить на МБР (не на раздел, например, вот) диска, что ваш BIOS загрузку с (не думайте, что вы знаете, кто это, он обычно не один, люди думают, что загрузившись с при наличии нескольких жестких дисков). Если у вас несколько дисков, то, наверное, лучше установить загрузочный сектор жратвы на всех из них.

Чтобы установить GRUB с LiveCD, следовать этому руководству: https://help.ubuntu.com/community/Grub2#ChRoot

+709
Rafnsvart 1 янв. 2019 г., 2:24:58

Я хотел бы быть в состоянии выбрать любое уже открытое окно и свернуть его из командной строки. Это возможно?

+626
Lookas 20 июл. 2015 г., 13:39:57

Привет я установил драйвер для моего HP павильон dv6 сдержащих АМД с переключаемой графикой с Xubuntu в 12.10.

Все вроде работает нормально, но игры не загружаются хорошо, и если я использую команду:

LIBGL_DEBUG=verbose вывести fglrxinfo

Я получаю эти ошибки:

 это libGL: OpenDriver: попытка файл /usr/lib в/для i386-линукс-дистрибутив GNU/Дри/ТЛС/i965_dri.так
это libGL: OpenDriver: попытка файл /usr/lib в/для i386-линукс-дистрибутив GNU/Дри/i965_dri.так
ошибка это libGL: функции выглядит /УСР/Либ/для i386-линукс-дистрибутив GNU/Дри/i965_dri.так что не удалось (в/usr/lib в/для i386-линукс-дистрибутив GNU/Дри/i965_dri.так: неправильный эльф класс: ELFCLASS32)
это libGL: OpenDriver: попытка файл /usr/lib в/x86_64 с-линукс-дистрибутив GNU/Дри/ТЛС/i965_dri.так
это libGL: OpenDriver: попытка файл /usr/lib в/x86_64 с-линукс-дистрибутив GNU/Дри/i965_dri.так
это libGL: не могу открыть конфигурационный файл /etc/drirc: нет такого файла или каталога.
это libGL: не могу открыть конфигурационный файл /home/Жерар/.drirc: нет такого файла или каталога.
ошибка это libGL: драйвер не удалось загрузить: i965
это libGL: OpenDriver: попытка файл /usr/lib в/для i386-линукс-дистрибутив GNU/Дри/ТЛС/swrast_dri.так
это libGL: OpenDriver: попытка файл /usr/lib в/для i386-линукс-дистрибутив GNU/Дри/swrast_dri.так
ошибка это libGL: функции выглядит /УСР/Либ/для i386-линукс-дистрибутив GNU/Дри/swrast_dri.так что не удалось (в/usr/lib в/для i386-линукс-дистрибутив GNU/Дри/swrast_dri.так: неправильный эльф класс: ELFCLASS32)
это libGL: OpenDriver: попытка файл /usr/lib в/x86_64 с-линукс-дистрибутив GNU/Дри/ТЛС/swrast_dri.так
это libGL: OpenDriver: попытка файл /usr/lib в/x86_64 с-линукс-дистрибутив GNU/Дри/swrast_dri.так
это libGL ошибка: не удалось загрузить драйвер: swrast
дисплей: :0.0 экран: 0
В OpenGL производитель: компания ATI Technologies Инк
OpenGL в строке Renderer: серии AMD для Radeon 6700M HD качестве 
Версия OpenGL строку: 1.4 (2.1 (4.2.12173 профиль совместимости контексте 12.10.17))

Спасибо за вашу помощь.

Редактировать 1: Может это поможет:

найдите i965_dri.так
в /usr/lib в/для i386-линукс-дистрибутив GNU/Дри/i965_dri.так
в /usr/lib в/x86_64 с-линукс-дистрибутив GNU/Дри/i965_dri.так

Я не понимаю "-1" на мой вопрос, я только задаю вопросы, мой последний альтернатива.

Правка 2: я пытался переустановить драйверы, и теперь я получаю эту ошибку на одном из шагов:

Жерар@Жерар-НР-павильон-и dv6:~$ судо apt-получить -г установить fglrx от-обновления fglrx от-amdcccle-обновления
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующий пакет был установлен автоматически и больше не требуется:
в Python-keybinder
Воспользоваться 'apt-получить autoremove', чтобы удалить его.
Следующие новые пакеты будут установлены:
 fglrx от-amdcccle-обновления fglrx от-обновления
Обновлено 0, 2 установлено новых, 0 для удаления, и 0 пакетов не обновлено.
Нужно получить 0 б/93.0 МБ архивов.
После этой операции, 279 МБ дополнительного дискового пространства будет использовано.
(Чтение базы данных ... 184985 файлы и каталоги установлены.)
Распаковка fglrx от-обновления (от .../fglrx от-updates_2%3a12.100.3-0~andrik1_amd64.деб) ...
Один или несколько файлов были изменены с момента установки.
Удаление не будет завершено. Смотрите /etc/АТИ/fglrx от-удалить.журнал для детали.
с dpkg: ошибка при обработке файла /var/кэш/АПТ/архив/fglrx от-updates_2%3a12.100.3-0~andrik1_amd64.деб (--распаковать):
 подпроцесс новый сценарий, выполняемый до установки вернул код ошибки 1
Выбор ранее выбранных пакетов fglrx от-amdcccle-обновления.
Распаковка fglrx от-amdcccle-обновления (от .../fglrx от-amdcccle-updates_2%3a12.100.3-0~andrik1_amd64.деб) ...
Ошибки возникли при обработке:
в /var/кэш/АПТ/архив/fglrx от-updates_2%3a12.100.3-0~andrik1_amd64.деб
Е: суб-процесс /usr/бен/с dpkg вернул код ошибки (1)
+613
Bilal Gondal 15 дек. 2016 г., 10:43:30

Позвольте мне начать, сказав, что я полный новичок во всем Линукс. У меня старенький IBM ThinkPad с Т30 я хотел установить и изучать. Я скачал 32-разрядную версию Ubuntu 13.04. Я установил его и все было хорошо выглядят.

Проблема возникает после того, как я войти. Экран становится зернистым, и я не вижу ничего значки/меню и т. д. На рабочем столе. Тот же фоновый рисунок хорошо смотрится на установочном диске экран. Я бы подумал если бы это был просто вопрос видеокарта экран входа будет высокого качества, и я хотел увидеть что-то вроде значка или меню на рабочем столе.

Как Примечание стороны, я заметил, что когда я ввожу в командной строке я вижу "добро пожаловать на Ubuntu 13.04 (Linux, которые 3.8.0-19-generic и семейства i686)" – может означать, что я скачал 64 битную версию, даже если он был обозначен как 32-битную версию?

Какие мысли?

  • Компьютер: ThinkPad фирмы IBM Т30
  • Видеокарта: ATI мобильности Radeon 7500
  • Процессор: Мобильный Процессор Intel(R) Для Мобильного Пентиум(Р) Процессор-4 М
  • Беспроводная связь: технология Хокинга (работает нормально)
  • Компьютер подробные характеристики: http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-58227
+509
Norbert Bicsi 22 дек. 2013 г., 17:44:05

Arkose находится в репозитории начиная с Ubuntu 11.04 и все последний выпуск в настоящее время в репозитории Убунту 11.10.

К сожалению Arkose не будет установлен по умолчанию в Ubuntu, поэтому вам придется установить его из Центра программного обеспечения.

Это часть по умолчанию, хотя Эдубунту установить так что если вы ищете аромат Убунту доставка по умолчанию, то это :)

Я тоже обычно переносим любые новые версии Arkose на Ubuntu 10.10 и 11.04 в Arkose стабильного РРА: https://launchpad.net/~arkose-девел/+архив/стабильный

Я также пытаюсь отодвинуть использования Arkose и аналогичной технологии для приложений, доступных в программном обеспечении пост-релиз центра, как это происходит через Совет по рассмотрению заявления и через коммерческий процесс. Это не дело, но может быть в ближайшем будущем. В таком случае, Arkose станет зависимость от любой упаковки, требующей его и потянули бы на вашем компьютере при установки одного из этих приложений.

+504
Anti NWO 2 июн. 2018 г., 17:22:39

Теперь я не использовать мульти-сенсорная панель, но так, как я это двойное касание (одним пальцем два раза) в заголовке, но в последний активный отдых и перетащите его.

Вы могли убедиться в "Включить кликов мыши с тачпадом" включена в настройках сенсорной панели мыши.

+482
user9931 28 июл. 2017 г., 22:33:41

Я использую виртуальный ПК с Windows 7 полную версию, у меня AMD процессор, мне установили Windows XP в режиме, который отлично работает, хочу установить Ubuntu Linux, операционная система, но не так далеко, я искал в Гугле и до сих пор не может исправить.

Сообщение об ошибке:

Это ядро требует x86-64 на ЦП, но обнаружил только процессор семейства i686. Не удается загрузиться - пожалуйста, используйте ядро подходящие для вашего процессора.

Я создал новый диск в виртуальный ПК 512m, и скачать .ISO-файл(ы), это дает ту же ошибку, могу ли я использовать 32-битный или 64 битный. Я даже проверил параметр настройки для виртуализации : что включено.

Кто-нибудь знает как это исправить? спасибо заранее.

+441
robben 5 нояб. 2012 г., 20:21:40

Возможные Дубликаты:
Где я могу посмотреть историю моих обновлений?

В менеджер пакетов Synaptic и Центр программного обеспечения Ubuntu я могу просмотреть историю последних пакетов обновлений. Как я могу сделать то же самое из командной строки?

+411
user334189 23 дек. 2018 г., 0:14:10

Я получил письма с расширением EML файл прилагается. Я использую Thunderbird, но он не откроет его.

Может кто-нибудь подсказать программу для открытия файла с расширением EML файлы?

Обновление:

Я не хочу, чтобы импортировать мой почтовый ящик я только хочу, чтобы прочитать содержимое в EML файл.

+405
Sovushka 14 июл. 2011 г., 7:12:06

что эквивалентно раздела магия для Ubuntu?

+395
Kolaposki 18 февр. 2019 г., 12:10:22

В случае если кто-то еще есть эта проблема - попробуйте эту команду в терминале:

судо команды dpkg-перенастроить клавиатуру-конфигурации
+368
Kranio23 25 сент. 2018 г., 20:01:54

Лучший способ получить последнюю версию, чтобы получить его непосредственно с сайта авторов.

Это требует времени и энергии, чтобы превратить программное обеспечение в красивые пакеты Ubuntu. Иногда это может быть некоторое время, прежде чем он появится в репозиториях Ubuntu. Вы можете попробовать включить менее стабильных репозиториев, таких как бэкпортов, но в этом случае, глоток 2.0.9 нет. Иногда бывают неофициальных репозиториев, но я не мог найти один из быстрый Google.

Есть несколько негативов. Программное обеспечение, как правило, не будет автоматическим самообновлением, в отличие от репозитория пакетов. Программное обеспечение не тестировалось на совместимость с Ubuntu для разработчиков, так что там могут быть некоторые глюки. Наконец, иногда зависимости запакованы в само программное обеспечение, так что по эксплуатации скачать может быть больше, чем в репозитории, версии.

Новые версии Убунту выходят каждые шесть месяцев. В каждый релиз Ubuntu, новые версии программного обеспечения, которые добавляют новые функции, как правило, не предусмотрено. Вообще говоря, за один выпуск Ubuntu, только безопасности и стабильности исправления серьезных выкатили. Обновление до следующей версии обновления программного обеспечения до версии, которая считается стабильной, когда релиз вышел. Вы можете иногда использовать бэкпорты и ППА , чтобы получить обновления программного обеспечения в рамках одного релиза, но вообще говоря, если вам нужна последняя версия программы, скорее всего, вам нужно скачать исходный код и собрать и установить его самостоятельно (см. Также в данном руководстве).

+294
vancexu 5 июн. 2015 г., 4:40:21

Использовать "помм". Она избыточна (три программы все всплывающие чтобы сказать вам, что вы увеличили свой объем!), раздражает, и не работает для меня в любом случае (никакого эффекта). Однако, другие клянутся им. (Пожалуйста, отредактируйте это, как заставить их работать, если вы знаете. Бонус для выключения лишних деталей.)

+270
user2999894 7 мар. 2014 г., 4:55:26

Возможные Дубликаты:
Как получить беспроводной карты от Broadcom 43XX ВСМ работает

Я использовал 'дополнительных драйверов' установка 'ГНАУ от Broadcom драйвер беспроводной сети и он возвращает ошибку. В жокея.в журнале написано следующее множество раз.

2011-02-14 21:24:06,945 отладки: BroadcomWLHandler включен (а): kmod-инвалидов, bcm43xx: черный список, в43: черный список, b43legacy: черный список

После того, как он возвращает ошибку сетевая карта будет временно работать пока не перезагрузить ноутбук. Когда я перезагрузить я должен пройти процедуру снова пытаетесь активировать драйвер, возвращает ошибку, однако она работает временно.

Сетевой карты выглядит следующим образом на Dell Инспирон 1545:

Корпорация Broadcom BCM4312 802.11 b/г ЛП-уровня PHY [14e4:4315] Рэв 01

Я пытался решить это сам в течение многих часов. Любая помощь приветствуется.

+125
Domin 26 мар. 2014 г., 23:50:26

Этот вопрос не дубликат этот, потому что в моем случае, подключение к интернету не работает на любой версии Ubuntu в качестве хозяина (11.04, 12.04,.12.10), и решение тоже отличается, шахты нужны VirtualBox и пакет расширений с официального сайта, а не от ОСК, и это решило проблему.

Вот вопрос:

Я скачал VirtualBox от центра программного обеспечения Ubuntu и установил с Lubuntu и Windows с XP в среде VirtualBox. Оба подключены через NAT, я тоже пробовал другие варианты, но ни один из них не работает.

Как поделиться интернетом с ОС хоста к гостевой ОС? Я использую USB-модем мобильного широкополосного подключения на хост-ОС (Ubuntu дискретные).

Я читал без подключения к интернету в виртуальной коробке с хостом и виртуальной ОС будучи 12.04, но до сих пор я не знаю, что делать. Можете ли вы дать мне пошаговые решения?

+117
Skip Burns 25 нояб. 2017 г., 21:30:52

Похоже, Kubuntu было по-прежнему контролировать жратву. Когда вы удалили его, вы удалили файлы жратвы, необходимые для загрузки. К счастью, это должно быть легко исправить.

Поскольку вы уже на живой компакт-диск, я думаю, самый простой маршрут в chroot и запустить установочный скрипты установки. Начните с открытия вашего установки Ubuntu (корневой раздел, который содержит такие папки, как "и т. п.", "УСР", и "дом") в файл-браузере, чтобы смонтировать его.

Теперь откройте терминал.

Найти крепление Pount

В терминале, типа горе это будет распечатать несколько строк. Ищите ту, что упомянута ваша Убунту установка в /СМИ. Он будет выглядеть примерно так:

на /dev/sda1, поскольку на /СМИ/тип диск в ext4 (RW,в режиме)

В примере выше, устройство на/dev/sda1, поскольку и точки монтирования /носитель/диск. Запомните это, потому что мы будем использовать эту информацию позже.

Ряд шагов

Нам нужно настроить chroot для. Это означает, что мы будем связывать некоторые системные папки с LiveCD на установленную систему. Для этого вставьте следующий текст в терминале, но заменить /медиа/диск в точку монтирования вы нашли ранее:

для меня в sys Дев прок; делать судо горе ... персонализация /$я /медиа/диск/$Я; сделано

Приведенная выше команда выполняет следующие три команды:

судо горе ... привязать /dev /СМИ/диск/Дев
судо горе ... персонализация /системы /СМИ/диск/Сыс
судо горе ... персонализация /труды /СМИ/диск/прок

Это привязывает файл /sys, /dev и/ и /proc в те же папки в /Media/диск. Это означает, что /медиа/диск в/dev/ фактически /разработки/

Теперь мы готовы сделать chroot. В терминале введите функцию chroot /медиа/диск, где /Media/диск ваша точка монтирования.

Теперь вы должны увидеть командную оболочку с правами суперпользователя (приглашение должно закончиться в #). Любая команда, выполняемая здесь ограничивается установленной разделом, и (по большей части) работать так, как если бы Вы были на установленной системе.

Исправить загрузчик

Теперь все, что нам нужно установить загрузчик. В терминале, добавьте следующие две строки:

жратва-установка /Дев/СДА
обновление-жратва

Примечание: это предполагает, что у вас только один диск на вашем компьютере. Если у вас два, или если вы работаете с помощью LiveUSB диск, убедитесь, что вы заменить на/dev/ПДД в приведенной выше команде с устройства из "найти точку подключения" разделе выше. Не включают численность на конец устройства. Например, если устройство для вашего раздела на/dev/sdb2 буд ет экспортироваться, то вы должны использовать жратвы-установить на /dev/СКБ.

И вот оно! Если эти команды завершится без ошибки, перезапустите ваш компьютер.

+105
Kazero 21 июн. 2015 г., 8:06:43

Я скопировал все темы в /usr/доли/темы , но в GNOME оболочки инструмент я вижу только системные темы. Я хочу изменить фон окна. Темы система отстой! Что я должен делать?

+97
user77509 20 авг. 2013 г., 1:11:06

Это резюме по электронной почте из публичной библиотеки Осло, назвав их установки:

  • Публичный запуск ПК с Lubuntu
  • Они используют LXLauncher
  • Общественный ПК загружаться с сервера изображений (с использованием PXE, я полагаю?)
  • Они следуют Libki и Коха проектов тесно (не знаю как/если они их используют)

Библиотеки это люди создадут подробное описание их установки. Я буду редактировать и добавлять ссылки, когда я знаю больше.

+63
achmiral 23 авг. 2015 г., 15:06:42

Показать вопросы с тегом